Grafana - excluding null values from PromQL query

Hey all, really easy one for you - when running a PromQL query that returns series that have a null value, how do I exclude them from the timeseries panel?

sum by (host) (count_over_time(vector_open_connections{}[$__interval])) is the query I’m running, but sum by (host) (count_over_time(vector_open_connections{}[$__interval]) >= 0) doesn’t work and the old option to filter out null’s that was in v. 6 or 7 of Grafana doesn’t appear to be available in v8!

Have you tried a != (or some version of that) in your query?

I haven’t, but I’ve just found the button I was looking for - the old graph panel has a “Hide all series that are nulls” option, which is missing from the new Timeseries panel.

I’ll give your suggestion a go, it’s nothing major, just annoying when you’ve got 30 series and only 5 of them actually have values!