Grafana - JSON - Data source is not working

Hello, I’m new to Grafana and I’d like some help with loading a local JSON file. I have the Grafana server running on the same machine as the file. Since the JSON data source option asks for an HTTP URL, I launched a Python server and gave it the URL to my file (roughly ipaddress:port/filename.json). However, I get the error “Data source is not working.” Any help would be appreciated. Thanks!
(Alternatively, if there’s any way to just copy-paste the file, that would be fine with me too - I just didn’t see an option for it.)

are you trying to visualize the content of this file? long term how do you see this process happening or is this a one time thing?

you could use infinity plugin as follows by copying content of json file into the data area

Long term this process would only be used occasionally, ideally just by uploading a file. I tried using Infinity and pasted in the JSON, and got this error

The JSON itself is quite large, close to 15MB, could that be causing issues?

load a smaller sample of data to see if the size is the issue

what is the root source of this json file?

I tried a very short file and it seemed to work when copy-pasted in.

When using JSON data connection, the root is just ~

The short file still doesn’t work with the JSON data connection

are you sure it is valid json

check here