Kafka - confluent-libserdes-dev issue - Unable to correct problems, you have held broken packages

Hello, I have one question and don’t know where to post it.
It is related to installation of confluent-libserdes-dev package in ubuntu 20.04 following the steps from https://docs.confluent.io/platform/current/installation/installing_cp/deb-ubuntu.html.
It seems something is broken since a few days ago. One week ago it worked without any issues
It gives me a dependency issue:

 confluent-libserdes-dev : Depends: confluent-libserdes1 (= 7.1.1-1) but it is not going to be installed
                           Depends: confluent-libserdes++1 (= 7.1.1-1) but it is not going to be installed
 libavro-cpp-dev : Depends: libavro-cpp1 (= 1.8.0~1confluent7.1.1-1) but it is not going to be installed
[91mE: Unable to correct problems, you have held broken packages.```
I did some analysis and I think the confluent packages have been overwritten lately with some packages build for other configuration. Please see my analysis below:
This is the dependency list before (from a week ago):
```# apt-cache depends confluent-libserdes-dev
  Depends: confluent-libserdes1
  Depends: confluent-libserdes++1
# apt-cache depends confluent-libserdes++1
  Depends: libavro-cpp1
  Depends: libc6
  Depends: libgcc-s1
  Depends: libstdc++6
# apt-cache depends libavro-cpp1       
  Depends: libboost-iostreams1.71.0
  Depends: libc6
  Depends: libgcc-s1
  Depends: libstdc++6```
While trying to install now libavro-cpp1 it requires and older boost library version (1.54.0) instead of the official one from ubuntu 20.04 (1.71.0)
```# apt-get install libavro-cpp1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libavro-cpp1 : Depends: libboost-iostreams1.54.0 but it is not installable```
I think the entire confluent platform packages need to be rebuilt for ubuntu 20.04 (focal) configuration

Maybe it was your post to the google groups that flagged this - Yes, we’re aware internally, and will be administering a fix

This should be fixed now

Ensure you run apt update to update the apt metadata