Kafka - offset reset not working

Ok here is one weird issue that I am facing. I am trying to reset the topic for a consumer group. This is what I used.
./kafka-consumer-groups.sh --bootstrap-server --group group-tango --reset-offsets --to-earliest --topic topic-tango --execute
and the result that I got was.

group-tango  topic-tango      3           0
group-tango  topic-tango      0           0
group-tango  topic-tango      1           0
group-tango  topic-tango      5           0
group-tango  topic-tango      4           0
group-tango  topic-tango      2           0```
However, when I do
`./kafka-consumer-groups.sh --describe --bootstrap-server --group group-tango`
I am getting this.
group-tango  topic-tango  1           2              5               3     -           -    - ```
As you see offset reset is not working. Is there anyway to fix this.

If you consumed two messages from partition 1, then looks correct to me

But when I start consumer it is not consuming message from the beginning

I even tried changing consumer group name but no luck

--from-beginning (or auto.offset.reset) only applies if there is no committed offsets.

As shown, the committed offset for partition 1, for example, is not 0

So how do I force consumer to start consuming message from the beginning

I tried to reset offset bit it is not working. Basically all I want to consume message from that topic from the beginning.

Your reset command is correct. But seems some consumer for that group is consuming again after you reset.

Yeah thats true. I was under the impression that after reset consumer should be able to consumer message from the beginning.

It will, but only for the very first run.

Note: Your consumer can always call seekToBeginning if you always want to consume from the start

Thank you very much for your help. I found out what the issue was.