Resolving DNS issues in kubernetes cluster

Hi. I’m having DNS issues in my kubernetes cluster. I’m trying to install the openwhisk helm chart but it’s failing. The errors of the pods are things like that it cannot

I tried switching to google dns, but I’m not sure if I was successful. I don’t know how to check. I used the following command kubectl -n kube-system edit configmap coredns to edit the configmap. I edited this:

        forward . /etc/resolv.conf {
           max_concurrent 1000
to make it look like this:
```        prometheus :9153
        forward . {
           max_concurrent 1000
Then restarted coredns like this: `kubectl rollout restart -n kube-system deployment/coredns` .
But no luck.

I've also tried setting `resolv-conf` to a file that has `nameserver` in it, but no luck.

Any ideas?

Is it really a dns issue or a connectivity issue?

The host machines can connect to the internet just fine. And they can resolve dns queries too.

I was referring to connectivity from the pod

It seems that the connection is fine.

I created a “dnsutils” pods, and I ping with it, and it pings just fine.

Was this test pod created on the same node as the pod with issue?

45 packets transmitted, 45 received, 0% packet loss, time 44067ms

;; connection timed out; no servers could be reached```

Yes same node. Master node.

Oh wait. I’m actually not sure where the openwhisk nodes are created. Let me check.

I see. The openwhisk nodes are on the worker node.

Please try nslookup [](


Non-authoritative answer:
Name:   [](

Does running ping []( from the pod work?

So no issues with resolving and connecting.

Yes. But the pod is not running on the worker node. It’s running on the master node.

You will probably need to debug the openwhisk to identify what the exact issue is

Both are running on the worker node.

So this is an openwhisk issue?

Too early to say until the error msgs are inspected and pod is debugged